Bugreport: Tide chart rendering glitch

  • Stewart
  • Auteur du sujet
  • Nouveau membre
  • Nouveau membre
Plus d'informations
il y a 2 semaines 2 jours #897 par Stewart
Bugreport: Tide chart rendering glitch a été créé par Stewart
   Error in graphical rendering of tide chart.  When I scroll time left to right, the white dot with text for time and tide seems to report ok, but the summary text in the upper right is unrealistic, and there is a different graphical error in the chart itself.  ( I could not capture the white dot in a screenshot )  
    I'm using harmonics-dwf-20191229-free.tcd from flaterco.com/xtide/files.html#harmonicsfiles and this file renders properly in xtide.

    secondarily / other bug : the y axis of tide charts never show the negative parts of the charts.
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

  • maitai
  • Administrateur
  • Administrateur
Plus d'informations
il y a 1 semaine 5 jours #902 par maitai
Réponse de maitai sur le sujet Bugreport: Tide chart rendering glitch
Hi,
Thanks for the report. I can see the problem with this strange station.

Wondering what a negative water level is meaning, can you explain ?

-- Philippe

Connexion ou Créer un compte pour participer à la conversation.

  • Stewart
  • Auteur du sujet
  • Nouveau membre
  • Nouveau membre
Plus d'informations
il y a 1 semaine 5 jours #903 par Stewart
Réponse de Stewart sur le sujet Bugreport: Tide chart rendering glitch
The zero line an abstract idea, more precisely it is 'mean lower low water.' There is no particular geographic location at which this zero line is defined. It is a statistical convenience, a created point of reference. In the second photo I attatched above, the xtide graph in the middle of the screenshot shows our local tides crossing the zero line several times and nothing special happening. Here is a bookmark to a big USA NOAA glossary tidesandcurrents.noaa.gov/glossary.html.

I think the station data in this case is good, nothing special, and there is some quirky rendering error in the qtVlm graphical rendering, like a untrapped divide by zero error or something.

thanks Stewart
Je ne pe pas ecrit le Fransais excuses moi

Connexion ou Créer un compte pour participer à la conversation.

  • maitai
  • Administrateur
  • Administrateur
Plus d'informations
il y a 1 semaine 5 jours #904 par maitai
Réponse de maitai sur le sujet Bugreport: Tide chart rendering glitch
OK, I have made some changes to accommodate this. If you are running qtVlm on Windows it is easy to send you a patched version to test.

Connexion ou Créer un compte pour participer à la conversation.

  • Stewart
  • Auteur du sujet
  • Nouveau membre
  • Nouveau membre
Plus d'informations
il y a 1 semaine 4 jours #905 par Stewart
Réponse de Stewart sur le sujet Bugreport: Tide chart rendering glitch
I run it on Android 11 and Debian buster. I could install it on my rarely used windows partition to test it.

I see several older versions of vlm & qtVlm on github: is qtVlm not open source now?

Connexion ou Créer un compte pour participer à la conversation.

  • maitai
  • Administrateur
  • Administrateur
Plus d'informations
il y a 1 semaine 2 jours #906 par maitai
Réponse de maitai sur le sujet Bugreport: Tide chart rendering glitch
No qtVlm is not open souce
There is a pre release of p1 available here can you please check the tide issue is fixed ?
www.virtual-winds.org/maitai/qtVlm-5.10.3-64_1-patch1.tar.gz

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.062 secondes