Navigation and Weather Routing software

AppStore PlayStore

Contact us for support or information: contact@meltemus.com

Bugreport: Tide chart rendering glitch

  • Stewart
  • Topic Author
  • New Member
  • New Member
More
2 weeks 2 days ago #897 by Stewart
   Error in graphical rendering of tide chart.  When I scroll time left to right, the white dot with text for time and tide seems to report ok, but the summary text in the upper right is unrealistic, and there is a different graphical error in the chart itself.  ( I could not capture the white dot in a screenshot )  
    I'm using harmonics-dwf-20191229-free.tcd from flaterco.com/xtide/files.html#harmonicsfiles and this file renders properly in xtide.

    secondarily / other bug : the y axis of tide charts never show the negative parts of the charts.
Attachments:

Please Log in or Create an account to join the conversation.

  • maitai
  • Administrator
  • Administrator
More
1 week 5 days ago #902 by maitai
Replied by maitai on topic Bugreport: Tide chart rendering glitch
Hi,
Thanks for the report. I can see the problem with this strange station.

Wondering what a negative water level is meaning, can you explain ?

-- Philippe

Please Log in or Create an account to join the conversation.

  • Stewart
  • Topic Author
  • New Member
  • New Member
More
1 week 5 days ago #903 by Stewart
Replied by Stewart on topic Bugreport: Tide chart rendering glitch
The zero line an abstract idea, more precisely it is 'mean lower low water.' There is no particular geographic location at which this zero line is defined. It is a statistical convenience, a created point of reference. In the second photo I attatched above, the xtide graph in the middle of the screenshot shows our local tides crossing the zero line several times and nothing special happening. Here is a bookmark to a big USA NOAA glossary tidesandcurrents.noaa.gov/glossary.html.

I think the station data in this case is good, nothing special, and there is some quirky rendering error in the qtVlm graphical rendering, like a untrapped divide by zero error or something.

thanks Stewart
Je ne pe pas ecrit le Fransais excuses moi

Please Log in or Create an account to join the conversation.

  • maitai
  • Administrator
  • Administrator
More
1 week 5 days ago #904 by maitai
Replied by maitai on topic Bugreport: Tide chart rendering glitch
OK, I have made some changes to accommodate this. If you are running qtVlm on Windows it is easy to send you a patched version to test.

Please Log in or Create an account to join the conversation.

  • Stewart
  • Topic Author
  • New Member
  • New Member
More
1 week 4 days ago #905 by Stewart
Replied by Stewart on topic Bugreport: Tide chart rendering glitch
I run it on Android 11 and Debian buster. I could install it on my rarely used windows partition to test it.

I see several older versions of vlm & qtVlm on github: is qtVlm not open source now?

Please Log in or Create an account to join the conversation.

  • maitai
  • Administrator
  • Administrator
More
1 week 2 days ago #906 by maitai
Replied by maitai on topic Bugreport: Tide chart rendering glitch
No qtVlm is not open souce
There is a pre release of p1 available here can you please check the tide issue is fixed ?
www.virtual-winds.org/maitai/qtVlm-5.10.3-64_1-patch1.tar.gz

Please Log in or Create an account to join the conversation.

Time to create page: 0.054 seconds